Skip to main content
VulnerabilityPublished

CVE-2026-34543: AcademySoftwareFoundation openexr · Use of Uninitialized Resource

Affects AcademySoftwareFoundation openexrSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 8.7 High : upgrade to 3.4.8 soon.

Data as of 30 Oct 2026, 06:59 UTC

CVSS 4.0 base score
8.7High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.5% chance of exploitation in 30 days – higher than 42% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 3.4.8
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 1 Apr 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade openexr and academysoftwarefoundation/openexr to 3.4.8.

Affected software

ProductAffectedFixed in
AcademySoftwareFoundationopenexrAffected
  • >=3.4.0 <3.4.8
Fixed in
  • 3.4.8
GitHubacademysoftwarefoundation/openexrpkg:github/academysoftwarefoundation/openexrOther threatsAffected
  • <3.4.8 >=3.4.0
Fixed in
  • 3.4.8

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade openexr to version 3.4.8 or later, where this vulnerability has been patched. If you cannot patch yet, avoid processing untrusted or unauthenticated EXR files to reduce risk of information disclosure.

Description

A vulnerability in AcademySoftwareFoundation's openexr versions 3.4.0 up to but not including 3.4.8 allows sensitive heap memory information to be leaked through decoded pixel data. This information disclosure occurs simply by reading a malicious EXR file with default settings, without any user interaction. The issue is due to use of uninitialized resource (CWE-908). The vulnerability has been patched in version 3.4.8.

References

Community reviews

Loading reviews…