Skip to main content
VulnerabilityPublished

CVE-2026-34544: AcademySoftwareFoundation openexr · Integer Overflow or Wraparound

Affects AcademySoftwareFoundation openexrSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 8.4 High : upgrade to 3.4.8 soon.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 4.0 base score
8.4High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 16% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 3.4.8
CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:A/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 1 Apr 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade openexr and academysoftwarefoundation/openexr to 3.4.8.

Affected software

ProductAffectedFixed in
AcademySoftwareFoundationopenexrAffected
  • >=3.4.0 <3.4.8
Fixed in
  • 3.4.8
GitHubacademysoftwarefoundation/openexrpkg:github/academysoftwarefoundation/openexrOther threatsAffected
  • <3.4.8 >=3.4.0
Fixed in
  • 3.4.8

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade to openexr version 3.4.8 or later, where this vulnerability has been patched. No other mitigation steps are indicated.

Description

A high-severity integer overflow vulnerability exists in AcademySoftwareFoundation's openexr library versions 3.4.0 up to but not including 3.4.8. This flaw occurs when processing crafted B44 or B44A EXR image files, leading to an out-of-bounds write during decoding. The issue can cause application crashes or heap corruption depending on memory layout. The vulnerability has been addressed in version 3.4.8.

References

Community reviews

Loading reviews…