Skip to main content
VulnerabilityPublished

CVE-2026-34565: ci4-cms-erp ci4ms · Cross-site Scripting

Affects ci4-cms-erp ci4msSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 9.1 Critical : upgrade to 0.31.0.0 as a priority.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 3.1 base score
9.1Critical
How severe the flaw is on the 0–10 CVSS scale.

Contested

Critical score, yet low EPSS after six months
EPSS
0.2% chance of exploitation in 30 days – higher than 19% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 0.31.0.0
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:L/A:L

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 1 Apr 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade ci4ms and ci4-cms-erp/ci4ms to 0.31.0.0.

Affected software

ProductAffectedFixed in
ci4-cms-erpci4msAffected
  • <0.31.0.0
Fixed in
  • 0.31.0.0
GitHubci4-cms-erp/ci4mspkg:github/ci4-cms-erp/ci4msOther threatsAffected
  • <0.31.0.0
Fixed in
  • 0.31.0.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch fixing this vulnerability is available in ci4ms version 0.31.0.0. Users should upgrade to this version or later to remediate the issue. No additional mitigation steps are indicated by the vendor advisory.

Description

CI4MS versions prior to 0.31.0.0 contain a stored DOM-based cross-site scripting (XSS) vulnerability in the Menu Management functionality. This occurs because user-controlled input related to Posts added to navigation menus is stored and later rendered without proper output encoding. The vulnerability affects both administrative dashboards and public-facing navigation menus. It has been patched in version 0.31.0.0.

References

Community reviews

Loading reviews…