CVE-2026-34569: ci4-cms-erp ci4ms · Cross-site Scripting
Affects ci4-cms-erp ci4msSource CVE Database V5
Not known to be exploited · CVSS 10.0 Critical : upgrade to 0.31.0.0 as a priority.
Data as of 26 Oct 2026, 06:26 UTC
- EPSS
- 0.3% chance of exploitation in 30 days – higher than 25% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 0.31.0.0
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 1 Apr 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-26.
What to do
Upgrade ci4ms and ci4-cms-erp/ci4ms to 0.31.0.0.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| ci4-cms-erpci4ms | Affected
| Fixed in
|
GitHubci4-cms-erp/ci4mspkg:github/ci4-cms-erp/ci4msOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade ci4ms to version 0.31.0.0 or later, where this vulnerability has been patched. No other mitigations are indicated or required as the fix addresses the root cause by properly sanitizing and encoding user input in the blog category title field.
Description
CVE-2026-34569 is a critical stored cross-site scripting (XSS) vulnerability in ci4ms, a CodeIgniter 4-based CMS skeleton. Versions prior to 0.31.0.0 do not properly sanitize user input in the blog category title field, allowing attackers to inject malicious JavaScript payloads. These payloads are stored server-side and rendered unsafely on public blog category pages, admin interfaces, and blog post views without proper output encoding. This can lead to full compromise of confidentiality, integrity, and availability of the affected system. The vulnerability has been patched in version 0.31.0.