CVE-2026-3457: Thalesgroup Sentinel LDK Runtime · XSS or 'Cross-site Scripting'
Affects Thalesgroup Sentinel LDK RuntimeSource CVE Database V5
Public exploit available · CVSS 7.0 High : upgrade to 10.22 as a priority.
Data as of 30 Oct 2026, 11:52 UTC
- EPSS
- 0.1% chance of exploitation in 30 days – higher than 2% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 10.22
CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:N/VC:L/VI:H/VA:N/SC:L/SI:H/SA:N/E:PExploitation evidence
Disclosed: evidence found.
CVE published 27 Mar 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: evidence found.
CVSS exploit maturity: proof of concept public
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), CVSS vector, the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Upgrade Thalesgroup Sentinel LDK Runtime to 10.22.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| ThalesgroupSentinel LDK Runtime | Affected
| Fixed in
|
AI-suggested
If you cannot patch yet, users should limit local access to the Sentinel LDK Runtime environment and monitor for any unusual activity related to web page generation within the application. Avoid running untrusted code or input through the affected versions. Stay alert for updates from Thales regarding patches or workarounds.
Description
Improper Neutralization of Input During Web Page Generation (XSS or 'Cross-site Scripting') vulnerability in Thales Sentinel LDK Runtime on Windows allows Stored XSS. This issue affects Sentinel LDK Runtime: before 10.22.