CVE-2026-34584: knadh listmonk · Insecure Direct Object Reference
Affects knadh listmonkSource CVE Database V5
Not known to be exploited · CVSS 5.4 Medium : upgrade to 6.1.0 when convenient.
Data as of 30 Oct 2026, 11:52 UTC
- EPSS
- 0.1% chance of exploitation in 30 days – higher than 6% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 6.1.0
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:NExploitation evidence
Disclosed: evidence found.
CVE published 2 Apr 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Upgrade listmonk and knadh/listmonk to 6.1.0.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| knadhlistmonk | Affected
| Fixed in
|
GitHubknadh/listmonkpkg:github/knadh/listmonkOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade listmonk to version 6.1.0 or later, where this authorization bypass vulnerability has been fixed. Since this is a self-hosted product, administrators should apply the update promptly to mitigate the risk. No additional vendor advisories indicate alternative mitigations or that no action is required.
Description
A vulnerability in listmonk versions 4.1.0 up to but not including 6.1.0 allows users in multi-user environments with untrusted users to bypass authorization checks and access mailing lists they should not have access to. This issue arises from bugs in list permission checks. The vulnerability has been patched in version 6.1.0. It has a medium severity with a CVSS score of 5.