Skip to main content
VulnerabilityPublished

CVE-2026-34602: chamilo-lms · Insecure Direct Object Reference

Affects chamilo-lmsSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 7.1 High : upgrade to 2.0.0-RC.3 soon.

Data as of 29 Oct 2026, 19:04 UTC

CVSS 3.1 base score
7.1High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 10% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 2.0.0-RC.3
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:H/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 14 Apr 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade chamilo-lms to 2.0.0-RC.3.

Affected software

ProductAffectedFixed in
chamilochamilo-lmsAffected
  • <2.0.0-RC.3
Fixed in
  • 2.0.0-RC.3
GitHubchamilo/chamilo-lmspkg:github/chamilo/chamilo-lmsOther threatsAffected
  • =2.0.0-RC.3
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

This vulnerability is fixed in Chamilo LMS version 2.0.0-RC.3. Users should upgrade to this version or later to remediate the issue. Since this is not a cloud service, patching the affected software is required to mitigate the risk. Patch status is confirmed by the vendor advisory stating the fix is included in version 2.0.0-RC.3.

Description

Chamilo LMS versions prior to 2.0.0-RC.3 contain an authorization bypass vulnerability in the /api/course_rel_users endpoint. An authenticated attacker can manipulate the user parameter to enroll arbitrary users into courses without proper authorization. This occurs because the backend does not verify ownership or permission for the user ID supplied. The vulnerability allows unauthorized access to course materials and compromises enrollment controls. The issue is fixed in version 2.0.0-RC.

References

Community reviews

Loading reviews…