Skip to main content
VulnerabilityPublished Updated

CVE-2026-34756: vllm · Unthrottled Resource Allocation

Affects vllmSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 6.5 Medium : upgrade to 0.19.0 when convenient.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 3.1 base score
6.5Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.4% chance of exploitation in 30 days – higher than 36% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 0.19.0
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 6 Apr 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade vllm to 0.19.0.

Affected software

ProductAffectedFixed in
vllm-projectvllmAffected
  • >=0.1.0 <0.19.0
Fixed in
  • 0.19.0
PyPIvllmpkg:pypi/vllmOther threatsAffected
  • <0.19.0 >=0.1.0
Fixed in
  • 0.19.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

The vulnerability is fixed in vLLM version 0.19.0. Users should upgrade to vLLM 0.19.0 or later to remediate this issue. The Red Hat advisory referencing this CVE does not explicitly confirm a patch or fix availability for their AI Inference Server product, so users should consult the vendor advisory for the latest remediation guidance. Until patched, consider restricting access to the vulnerable API endpoints or implementing request size limits at network or application layers to mitigate exploitation risk.

Description

vLLM is an inference and serving engine for large language models (LLMs). From 0.1.0 to before 0.19.0, a Denial of Service vulnerability exists in the vLLM OpenAI-compatible API server. Due to the lack of an upper bound validation on the n parameter in the ChatCompletionRequest and CompletionRequest Pydantic models, an unauthenticated attacker can send a single HTTP request with an astronomically large n value. This completely blocks the Python asyncio event loop and causes immediate Out-Of-Memory crashes by allocating millions of request object copies in the heap before the request even reaches the scheduling queue. This vulnerability is fixed in 0.19.0.

References

Community reviews

Loading reviews…