Skip to main content
VulnerabilityPublished Updated

CVE-2026-34828: knadh listmonk · Insufficient Session Expiration

Affects knadh listmonkSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 7.1 High : upgrade to 6.1.0 soon.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 3.1 base score
7.1High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.3% chance of exploitation in 30 days – higher than 22% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 6.1.0
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:L/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 2 Apr 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: evidence found.

    Public exploit code: GitHub proofs of concept

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), GitHub proofs of concept, the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade listmonk and knadh/listmonk to 6.1.0.

Affected software

ProductAffectedFixed in
knadhlistmonkAffected
  • >=4.1.0 <6.1.0
Fixed in
  • 6.1.0
GitHubknadh/listmonkpkg:github/knadh/listmonkOther threatsAffected
  • <6.1.0 >=4.1.0
Fixed in
  • 6.1.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade listmonk to version 6.1.0 or later, where this session management vulnerability has been fixed. Since this is a self-hosted product, administrators must apply the update themselves to ensure sessions are properly invalidated after password changes or resets.

Description

listmonk is a standalone, self-hosted, newsletter and mailing list manager. From version 4.1.0 to before version 6.1.0, a session management vulnerability allows previously issued authenticated sessions to remain valid after sensitive account security changes, specifically password reset and password change. As a result, an attacker who has already obtained a valid session cookie can retain access to the account even after the victim changes or resets their password. This weakens account recovery and session security guarantees. This issue has been patched in version 6.1.0.

References

Community reviews

Loading reviews…