CVE-2026-34841: usebruno bruno · Download of Code Without Integrity Check
Affects usebruno brunoSource CVE Database V5
Not known to be exploited · CVSS 9.8 Critical : upgrade to 3.2.1 as a priority.
Data as of 30 Oct 2026, 11:52 UTC
Contested
Critical score, yet low EPSS after six months- EPSS
- 0.2% chance of exploitation in 30 days – higher than 14% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 3.2.1
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 6 Apr 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Upgrade bruno and @usebruno/cli to 3.2.1.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| usebrunobruno | Affected
| Fixed in
|
npm@usebruno/clipkg:npm/@usebruno/cliOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Users should upgrade Bruno to version 3.2.1 or later to remediate this vulnerability. Since the attack was time-limited and involved a specific compromised package version, users who installed the affected versions during the incident window should audit their systems for potential compromise. Patch status is not explicitly confirmed in the advisory, but the upgrade to 3.2.1 is indicated as the fix. No cloud service remediation applies as Bruno is not a cloud service.
Description
Bruno, an open source IDE for API testing, was affected by a supply chain attack prior to version 3.2.1. The attack involved compromised versions of the axios npm package, which introduced a hidden dependency deploying a cross-platform Remote Access Trojan (RAT). Users of @usebruno/cli who ran npm install between 00:21 UTC and approximately 03:30 UTC on March 31, 2026, may have been impacted. The vulnerability is addressed by upgrading to version 3.2.1.