Skip to main content
VulnerabilityPublished

CVE-2026-34889: Ultimate Addons for WPBakery Page Builder (WordPress plugin) · Cross-site Scripting

Affects Ultimate Addons for WPBakery Page Builder (WordPress plugin)Source CVE Database V5

0
Compare

Not known to be exploited · CVSS 6.5 Medium : upgrade to 3.21.4 when convenient.

Data as of 29 Oct 2026, 19:04 UTC

CVSS 3.1 base score
6.5Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.1% chance of exploitation in 30 days – higher than 7% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 3.21.4
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:L

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 1 Apr 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade Ultimate Addons for WPBakery Page Builder (WordPress plugin) to 3.21.4.

Affected software

ProductAffectedFixed in
Brainstorm ForceUltimate Addons for WPBakery Page BuilderAffected
  • ≥ n/a, < 3.21.4
Fixed in
  • 3.21.4

AI-suggested

If you cannot patch yet, users should exercise caution with untrusted input and consider temporary mitigations such as disabling or restricting the vulnerable plugin functionality if feasible.

Description

CVE-2026-34889 is a medium severity vulnerability in Brainstorm Force Ultimate Addons for WPBakery Page Builder that allows DOM-based Cross-site Scripting (XSS) due to improper neutralization of input during web page generation. This vulnerability affects versions before 3.21.4. It requires low attack complexity but privileges and user interaction, and it impacts confidentiality, integrity, and availability to a limited extent.

References

Community reviews

Loading reviews…