CVE-2026-34974: thorsten phpMyFAQ · Cross-site Scripting
Affects thorsten phpMyFAQSource CVE Database V5
Not known to be exploited · CVSS 5.4 Medium : upgrade to 4.1.1 when convenient.
Data as of 30 Oct 2026, 11:52 UTC
- EPSS
- 0.1% chance of exploitation in 30 days – higher than 7% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 4.1.1
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:NExploitation evidence
Disclosed: evidence found.
CVE published 2 Apr 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 24 Oct 2026.
What to do
Upgrade phpMyFAQ and thorsten/phpMyFAQ to 4.1.1.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| thorstenphpMyFAQ | Affected
| Fixed in
|
GitHubthorsten/phpMyFAQpkg:github/thorsten/phpMyFAQOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade phpMyFAQ to version 4.1.1 or later, where this vulnerability has been patched. No other mitigation is indicated or required as the fix addresses the root cause in the SVG sanitizer. Users should ensure they do not use vulnerable versions in production environments.
Description
phpMyFAQ versions prior to 4.1.1 contain a cross-site scripting (XSS) vulnerability in the SVG sanitizer. The issue arises because the regex-based sanitizer can be bypassed using HTML entity encoding in javascript: URLs within SVG <a href> attributes. An attacker with edit_faq permission can upload a malicious SVG that executes arbitrary JavaScript when viewed, potentially escalating privileges from editor to full admin. This vulnerability has been fixed in version 4.1.1.