Skip to main content
VulnerabilityPublished

CVE-2026-34992: antrea · Missing Encryption of Sensitive Data

Affects antreaSource CVE Database V5

0

Not known to be exploited · CVSS 7.1 High : upgrade to 2.5.2 or 2.4.5 soon.

Data as of 26 Oct 2026, 10:12 UTC

CVSS 4.0 base score
7.1High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.1% chance of exploitation in 30 days – higher than 1% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 2.5.2, 2.4.5, 2.5.3
CVSS:4.0/AV:A/AC:L/AT:N/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 6 Apr 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade antrea to 2.5.2 or 2.4.5; antrea-io/antrea to 2.5.3 or 2.4.5.

Affected software

ProductAffectedFixed in
antrea-ioantreaAffected
  • >=2.5.0 <2.5.2
Fixed in
  • 2.5.2
antrea-ioantreaAffected
  • <2.4.5
Fixed in
  • 2.4.5
GitHubantrea-io/antreapkg:github/antrea-io/antreaOther threatsAffected
  • <2.4.5
  • >=2.5.0 <2.5.3
Fixed in
  • 2.4.5
  • 2.5.3

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Users should upgrade Antrea to version 2.4.5 or later, or 2.5.2 or later, where this vulnerability is fixed. Since the vulnerability specifically affects dual-stack clusters with IPsec encryption enabled, verifying cluster configuration and applying the fixed versions will remediate the issue. Patch status is not explicitly stated beyond fixed versions; therefore, users should consult the vendor advisory for the latest remediation guidance.

Description

CVE-2026-34992 is a vulnerability in antrea-io's Antrea Kubernetes networking solution affecting versions prior to 2.4.5 and between 2.5.0 and 2.5.2. In dual-stack Kubernetes clusters configured with IPsec encryption enabled, IPv6 Pod traffic is not encrypted and is transmitted in plaintext, while IPv4 traffic remains encrypted. This occurs because the IPv6 packets bypass the IPsec encryption layer despite being encapsulated. Single-stack IPv4 or IPv6 clusters are not affected.

References

Community reviews

Loading reviews…