CVE-2026-35040: nearform fast-jwt · Incorrect Comparison
Affects nearform fast-jwtSource CVE Database V5
Not known to be exploited · CVSS 5.3 Medium : upgrade to 6.2.1 when convenient.
Data as of 25 Oct 2026, 19:02 UTC
- EPSS
- 0.3% chance of exploitation in 30 days – higher than 32% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 6.2.1
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:LExploitation evidence
Disclosed: evidence found.
CVE published 9 Apr 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-25.
What to do
Upgrade nearform fast-jwt to 6.2.1.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| nearformfast-jwt | Affected
| Fixed in
|
npmfast-jwtpkg:npm/fast-jwtOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade fast-jwt to version 6.2.1 or later, where this issue is fixed. No other mitigations are indicated or necessary since the vulnerability is resolved in the updated version. Patch status is confirmed by the versioning information in the advisory.
Description
fast-jwt provides fast JSON Web Token (JWT) implementation. Prior to 6.2.1, using certain modifiers on RegExp objects in the allowedAud, allowedIss, allowedSub, allowedJti, or allowedNonce options in verify functions can cause certain unintended behaviours. This is because some modifiers are stateful and will cause failures in every second verification attempt regardless of the validity of the token provided. Such modifiers are /g (global matching) and /y (sticky matching). This does NOT allow invalid tokens to be accepted, only for valid tokens to be improperly rejected in some configurations. Instead it causes 50% of valid authentication requests to fail in an alternating pattern. This vulnerability is fixed in 6.2.1.
References
- github.com/nearform/fast-jwt/security/advisories/GHSA-3j8v-cgw4-2g6q (opens in a new tab)
- github.com/nearform/fast-jwt/pull/593 (opens in a new tab)
- github.com/nearform/fast-jwt/commit/18d25904e4617e8753526d1b3ab5a2cccdea726a (opens in a new tab)
- github.com/nearform/fast-jwt/releases/tag/v6.2.1 (opens in a new tab)