CVE-2026-35166: gohugoio hugo · Cross-site Scripting
Affects gohugoio hugoSource CVE Database V5
Not known to be exploited · CVSS 5.3 Medium : upgrade to 0.159.2 when convenient.
Data as of 30 Oct 2026, 06:59 UTC
- EPSS
- 0.1% chance of exploitation in 30 days – higher than 8% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 0.159.2
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:N/VA:N/SC:L/SI:L/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 6 Apr 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade hugo and github.com/gohugoio/hugo to 0.159.2.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| gohugoiohugo | Affected
| Fixed in
|
Gogithub.com/gohugoio/hugopkg:golang/github.com/gohugoio/hugoOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade to Hugo version 0.159.2 or later, where this vulnerability is fixed. Users who only use trusted Markdown content or have custom render hooks for links and images are not affected and may not require immediate action. No other mitigation steps are indicated by the vendor advisory.
Description
Hugo is a static site generator. From 0.60.0 to before 0.159.2, links and image links in the default markdown to HTML renderer are not properly escaped. Hugo users who trust their Markdown content or have custom render hooks for links and images are not affected. This vulnerability is fixed in 0.159.2.