CVE-2026-35173: xenocrat chyrp-lite · Insecure Direct Object Reference
Affects xenocrat chyrp-liteSource CVE Database V5
Not known to be exploited · CVSS 6.5 Medium : upgrade to 2026.01 when convenient.
Data as of 31 Oct 2026, 08:20 UTC
- EPSS
- 0.1% chance of exploitation in 30 days – higher than 6% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 2026.01
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:NExploitation evidence
Disclosed: evidence found.
CVE published 6 Apr 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Upgrade chyrp-lite and xenocrat/chyrp-lite to 2026.01.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| xenocratchyrp-lite | Affected
| Fixed in
|
GitHubxenocrat/chyrp-litepkg:github/xenocrat/chyrp-liteOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
This vulnerability is fixed in Chyrp Lite version 2026.01. Users should upgrade to version 2026.01 or later to remediate this issue. Patch status is not explicitly confirmed in the vendor advisory, but the description states the issue is fixed in 2026.01. No additional mitigation steps are indicated.
Description
Chyrp Lite is an ultra-lightweight blogging engine. Prior to 2026.01, an IDOR / Mass Assignment issue exists in the Post model that allows authenticated users with post editing permissions (Edit Post, Edit Draft, Edit Own Post, Edit Own Draft) to modify posts they do not own and do not have permission to edit. By passing internal class properties such as id into the post_attributes payload, an attacker can alter the object being instantiated. As a result, further actions are performed on another user’s post rather than the attacker’s own post, effectively enabling post takeover. This vulnerability is fixed in 2026.01.