CVE-2026-35174: xenocrat chyrp-lite · Path Traversal
Affects xenocrat chyrp-liteSource CVE Database V5
Not known to be exploited · CVSS 9.1 Critical : upgrade to 2026.01 as a priority.
Data as of 30 Oct 2026, 11:52 UTC
Contested
Critical score, yet low EPSS after six months- EPSS
- 0.5% chance of exploitation in 30 days – higher than 46% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 2026.01
CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 6 Apr 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Upgrade chyrp-lite and xenocrat/chyrp-lite to 2026.01.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| xenocratchyrp-lite | Affected
| Fixed in
|
GitHubxenocrat/chyrp-litepkg:github/xenocrat/chyrp-liteOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade Chyrp Lite to version 2026.01 or later, where this path traversal vulnerability is fixed. No other mitigation is indicated or required as the vendor has provided an official fix.
Description
CVE-2026-35174 is a critical path traversal vulnerability in the Chyrp Lite blogging engine prior to version 2026.01. It allows an administrator or a user with Change Settings permission to manipulate the uploads path to arbitrary directories. This enables unauthorized downloading of sensitive files such as configuration files containing database credentials and overwriting critical system files, potentially leading to remote code execution. The vulnerability is fixed in version 2026.01.