CVE-2026-35182: Ajax30 BraveCMS-2.0 · Missing Authorization
Affects Ajax30 BraveCMS-2.0Source CVE Database V5
Not known to be exploited · CVSS 8.8 High : upgrade to 2.0.6 soon.
Data as of 30 Oct 2026, 11:52 UTC
- EPSS
- 0.3% chance of exploitation in 30 days – higher than 26% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 2.0.6
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 6 Apr 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Upgrade BraveCMS-2.0 and ajax30/BraveCMS-2.0 to 2.0.6.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| Ajax30BraveCMS-2.0 | Affected
| Fixed in
|
GitHubajax30/BraveCMS-2.0pkg:github/ajax30/BraveCMS-2.0Other threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade BraveCMS to version 2.0.6 or later, where this authorization check vulnerability has been fixed. Since the vendor advisory confirms the fix in 2.0.6, applying this official update is the recommended remediation. No other mitigations are specified or required once the patch is applied.
Description
CVE-2026-35182 is a high-severity vulnerability in BraveCMS versions prior to 2.0.6. It involves a missing authorization check in the update role endpoint, allowing any authenticated user to escalate their privileges to Super Admin. The flaw exists because the POST route /rights/update-role/{id} does not enforce the required checkUserPermissions:assign-user-roles middleware. This vulnerability is fixed in BraveCMS version 2.0.6.