CVE-2026-35193: djangoproject Django · Use of Cache Containing Sensitive Information
Affects djangoproject DjangoSource CVE Database V5
Not known to be exploited · CVSS 3.1 Low : upgrade to 6.0.6 or 5.2.15 when convenient.
Data as of 30 Oct 2026, 11:52 UTC
- EPSS
- 0.3% chance of exploitation in 30 days – higher than 31% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 6.0.6, 5.2.15
CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:L/I:N/A:NExploitation evidence
Disclosed: evidence found.
CVE published 3 Jun 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Upgrade Django and django to 6.0.6 or 5.2.15.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| djangoprojectDjango | Affected
| Fixed in
|
| djangoprojectDjango | Affected
| Fixed in
|
PyPIdjangopkg:pypi/djangoOther threats | Affected
| Fixed in
|
PyPIdjangopkg:pypi/djangoOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A patch is available for this vulnerability. Users should upgrade Django to version 5.2.15 or later, or 6.0.6 or later to remediate the issue. There is no indication that earlier unsupported versions have official fixes; users of those versions should consider upgrading to a supported patched release. No additional mitigation steps are specified by the vendor.
Description
A vulnerability in Django's UpdateCacheMiddleware allows private cached responses to be read by unauthenticated remote attackers. This occurs because the middleware does not add the Authorization header to the Vary response header for requests that include Authorization without Cache-Control: public. The issue affects Django versions 5.2 before 5.2.15 and 6.0 before 6.0.6. Earlier unsupported versions may also be affected. The vulnerability has a low severity score and no known exploits in the wild.