Skip to main content
VulnerabilityPublished

CVE-2026-35197: mattieb dye · Code Injection

Affects mattieb dyeSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 6.6 Medium : upgrade to 1.1.1 when convenient.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 3.1 base score
6.6Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 21% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 1.1.1
CVSS:3.1/AV:L/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 6 Apr 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade dye and mattieb/dye to 1.1.1.

Affected software

ProductAffectedFixed in
mattiebdyeAffected
  • <1.1.1
Fixed in
  • 1.1.1
GitHubmattieb/dyepkg:github/mattieb/dyeOther threatsAffected
  • <1.1.1
Fixed in
  • 1.1.1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade dye to version 1.1.1 or later, where this vulnerability has been fixed. Since the vendor author has released a fixed version, applying this official update is the recommended remediation. Patch status is confirmed by the vendor's fix in version 1.1.1.

Description

CVE-2026-35197 is a code injection vulnerability in the dye color library for shell scripts prior to version 1.1.1. Certain dye template expressions could lead to arbitrary code execution. The issue was discovered and fixed by the author in version 1.1.1. There are no known exploits in the wild. The vulnerability has a CVSS score of 6.6, indicating medium severity.

References

Community reviews

Loading reviews…