CVE-2026-35207: linuxdeepin dde-control-center · Improper Certificate Validation
Affects linuxdeepin dde-control-centerSource CVE Database V5
Not known to be exploited · CVSS 5.4 Medium : upgrade to 6.1.80 or 5.9.9 when convenient.
Data as of 30 Oct 2026, 11:52 UTC
- EPSS
- 0.1% chance of exploitation in 30 days – higher than 3% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 6.1.80, 5.9.9
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:NExploitation evidence
Disclosed: evidence found.
CVE published 9 Apr 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Upgrade dde-control-center to 6.1.80 or 5.9.9; linuxdeepin/dde-control-center to 6.1.80.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| linuxdeepindde-control-center | Affected
| Fixed in
|
| linuxdeepindde-control-center | Affected
| Fixed in
|
| linuxdeepindeepin-deepinid-plugin | Affected
| Fixed in– |
GitHublinuxdeepin/dde-control-centerpkg:github/linuxdeepin/dde-control-centerOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
The vulnerability is fixed in dde-control-center versions 6.1.80 and 5.9.9. Users and administrators should upgrade affected dde-control-center installations to at least these versions to remediate the issue. Patch status is not explicitly stated as 'patchAvailable' in the data, but the vendor has fixed the issue in these versions, so updating to these or later versions is the recommended mitigation.
Description
dde-control-center is the control panel of DDE, the Deepin Desktop Environment.plugin-deepinid is a plugin in dde-control-center, which provides the deepinid cloud service. Prior to 6.1.80, plugin-deepinid is configured to skip TLS certificate verification when fetching the user's avatar from openapi.deepin.com or other providers. An MITM attacker could intercept the traffic, replace the avatar with a malicious or misleading image, and potentially identify the user by the avatar. This vulnerability is fixed in dde-control-center 6.1.80 and 5.9.9.
References
- github.com/linuxdeepin/developer-center/security/advisories/GHSA-jf2h-4vqc-3jgc (opens in a new tab)
- github.com/linuxdeepin/dde-control-center/pull/3146 (opens in a new tab)
- github.com/linuxdeepin/dde-control-center/commit/6fc206120be28d9eef7d72258662bcabb834367f (opens in a new tab)
- github.com/linuxdeepin/dde-control-center/commit/cd95b054ff10a35bc9284431631305bd56244b3d (opens in a new tab)