Skip to main content
CVE-2026-35337VulnerabilityPublished

CVE-2026-35337: Apache Storm Client · Deserialization of Untrusted Data

Affects Apache Storm ClientSource CVE Database V5

0

Not known to be exploited · CVSS 8.8 High : upgrade to 2.8.6 soon.

Data as of 25 Oct 2026, 19:02 UTC

CVSS 3.1 base score
8.8High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
1.0% chance of exploitation in 30 days – higher than 62% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 2.8.6
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 13 Apr 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-25.

What to do

Upgrade Apache Storm Client and Apache Software Foundation/org.apache.storm:storm-client and org.apache.storm/storm-client to 2.8.6.

Affected software

ProductAffectedFixed in
Apache Software FoundationApache Storm ClientAffected
  • <2.8.6
Fixed in
  • 2.8.6
MavenApache Software Foundation/org.apache.storm:storm-clientpkg:maven/Apache Software Foundation/org.apache.storm:storm-clientOther threatsAffected
  • <2.8.6
Fixed in
  • 2.8.6
Mavenorg.apache.storm/storm-clientpkg:maven/org.apache.storm/storm-clientOther threatsAffected
  • <2.8.6
Fixed in
  • 2.8.6

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade Apache Storm to version 2.8.6, which contains an official fix for this vulnerability. For users unable to upgrade immediately, apply a monkey-patch that adds an ObjectInputFilter allow-list to ClientAuthUtils.deserializeKerberosTicket(), restricting deserialized classes to javax.security.auth.kerberos.KerberosTicket and its dependencies. Follow the guidance provided in the 2.8.6 release notes for implementation details.

Description

Deserialization of Untrusted Data vulnerability in Apache Storm. Versions Affected: before 2.8.6. Description: When processing topology credentials submitted via the Nimbus Thrift API, Storm deserializes the base64-encoded TGT blob using ObjectInputStream.readObject() without any class filtering or validation. An authenticated user with topology submission rights could supply a crafted serialized object in the "TGT" credential field, leading to remote code execution in both the Nimbus and Worker JVMs. Mitigation: 2.x users should upgrade to 2.8.6. Users who cannot upgrade immediately should monkey-patch an ObjectInputFilter allow-list to ClientAuthUtils.deserializeKerberosTicket() restricting deserialized classes to javax.security.auth.kerberos.KerberosTicket and its known dependencies. A guide on how to do this is available in the release notes of 2.8.6. Credit: This issue was discovered by K.

References

Community reviews

Loading reviews…