CVE-2026-35389: bulwarkmail webmail · Improper Certificate Validation
Affects bulwarkmail webmailSource CVE Database V5
Not known to be exploited · CVSS 8.7 High : upgrade to 1.4.11 soon.
Data as of 30 Oct 2026, 11:52 UTC
- EPSS
- 0.1% chance of exploitation in 30 days – higher than 7% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 1.4.11
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:H/VA:N/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 6 Apr 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Upgrade webmail and bulwarkmail/webmail to 1.4.11.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| bulwarkmailwebmail | Affected
| Fixed in
|
GitHubbulwarkmail/webmailpkg:github/bulwarkmail/webmailOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade Bulwark Webmail to version 1.4.11 or later, where the certificate trust chain validation in S/MIME signature verification is properly enforced. Patch status is not explicitly stated but the fix is included in version 1.4.11. Users should verify they are running this version or newer to mitigate this vulnerability.
Description
Bulwark Webmail versions prior to 1.4.11 contain a vulnerability in S/MIME signature verification where the certificate trust chain was not validated. This means emails signed with self-signed or untrusted certificates were incorrectly shown as having valid signatures. The issue is addressed in version 1.4.11. The vulnerability has a high severity with a CVSS score of 8.7.