Skip to main content
VulnerabilityPublished

CVE-2026-35453: PHPOffice PhpSpreadsheet · Cross-site Scripting

Affects PHPOffice PhpSpreadsheetSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 4.8 Medium · fixed in 1.30.4 : update PHPOffice PhpSpreadsheet when convenient.

Data as of 2 Nov 2026, 22:58 UTC

CVSS 4.0 base score
4.8Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 10% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 1.30.4
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:A/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 5 May 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2 Nov 2026.

What to do

Affected software

ProductAffectedFixed in
PHPOfficePhpSpreadsheetAffected
  • >=4.0.0 <=5.6.0
  • >=3.3.0 <=3.10.4
  • >=2.2.0 <=2.4.4
  • >=2.0.0 <=2.1.15
  • <=1.30.3
Fixed in–
Packagistphpoffice/phpspreadsheetpkg:composer/phpoffice/phpspreadsheetOther threatsAffected
  • <=1.30.3
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrading to PhpSpreadsheet versions 1.30.4, 2.1.16, 2.4.5, 3.10.5, or 5.7.0 or later addresses this vulnerability. Since these fixed versions are identified, users should apply these official updates to remediate the issue. Patch status is not explicitly stated in the vendor advisory content, but the presence of fixed versions indicates an official fix is available. No additional mitigation steps are specified.

Description

CVE-2026-35453 is a cross-site scripting (XSS) vulnerability in the PHPOffice PhpSpreadsheet library affecting multiple versions up to 5.6.0. The issue arises because the HTML Writer component fails to properly escape output when a cell uses a custom number format with the @ text placeholder combined with additional literal text. This allows an attacker who can control spreadsheet cell content to inject arbitrary HTML and JavaScript into the generated output. The vulnerability has a medium severity with a CVSS score of 4.8. Fixes have been released in PhpSpreadsheet versions 1.30.4, 2.

References

Community reviews

Loading reviews…