CVE-2026-35462: papra · Insufficient Session Expiration
Affects papraSource CVE Database V5
Not known to be exploited · CVSS 4.3 Medium : upgrade to 26.4.0 when convenient.
Data as of 30 Oct 2026, 06:59 UTC
- EPSS
- 0.2% chance of exploitation in 30 days – higher than 14% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 26.4.0
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:NExploitation evidence
Disclosed: evidence found.
CVE published 7 Apr 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade papra and papra-hq/papra to 26.4.0.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| papra-hqpapra | Affected
| Fixed in
|
GitHubpapra-hq/paprapkg:github/papra-hq/papraOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade papra to version 26.4.0 or later, where the issue is fixed by proper validation of API key expiration dates during authentication. Since the vendor has fixed the vulnerability in this version, applying this official fix is the recommended remediation. Patch status is confirmed by the vendor advisory stating the fix is included in version 26.4.0.
Description
Papra versions prior to 26.4.0 contain a vulnerability where API keys with expiration dates are not validated against the current time during authentication. This means expired API keys remain valid indefinitely, allowing continued access to protected endpoints. The issue is identified as insufficient session expiration (CWE-613) and is fixed in version 26.4.0. The vulnerability has a medium severity with a CVSS score of 4.3.