Skip to main content
VulnerabilityPublished

CVE-2026-35470: devcode-it openstamanager · SQL Injection

Affects devcode-it openstamanagerSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 8.8 High : upgrade to 2.10.2 soon.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 3.1 base score
8.8High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.4% chance of exploitation in 30 days – higher than 35% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 2.10.2
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 6 Apr 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade openstamanager and devcode-it/openstamanager to 2.10.2.

Affected software

ProductAffectedFixed in
devcode-itopenstamanagerAffected
  • <2.10.2
Fixed in
  • 2.10.2
GitHubdevcode-it/openstamanagerpkg:github/devcode-it/openstamanagerOther threatsAffected
  • <2.10.2
Fixed in
  • 2.10.2

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fix for this vulnerability is available in OpenSTAManager version 2.10.2. Users and administrators should upgrade to version 2.10.2 or later to remediate this issue. Since the vendor advisory or patch links are not explicitly provided, verify the upgrade availability from the official devcode-it OpenSTAManager sources before applying.

Description

OpenSTAManager versions prior to 2.10.2 contain an SQL Injection vulnerability in the confronta_righe.php file. The vulnerability arises because the 'righe' parameter from user input is directly concatenated into an SQL query without sanitization or validation. An authenticated attacker can exploit this to execute arbitrary SQL commands, potentially accessing sensitive data such as user credentials, customer information, and invoice data. This vulnerability has a high severity rating with a CVSS score of 8.8. The issue is fixed in version 2.10.

References

Community reviews

Loading reviews…