CVE-2026-35560: Amazon Athena ODBC driver · Improper Certificate Validation
Affects Amazon Athena ODBC driverSource CVE Database V5
Not known to be exploited · CVSS 7.4 High : upgrade to 2.1.0.0 soon.
Data as of 29 Oct 2026, 19:04 UTC
- EPSS
- 0.2% chance of exploitation in 30 days – higher than 19% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 2.1.0.0
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:NExploitation evidence
Disclosed: evidence found.
CVE published 3 Apr 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade Amazon Athena ODBC driver and amazon/amazon-athena-odbc-driver to 2.1.0.0.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| AmazonAmazon Athena ODBC driver | Affected
| Fixed in
|
Amazonamazon/amazon-athena-odbc-driverpkg:rpm/amazon/amazon-athena-odbc-driverOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
AWS recommends upgrading the Amazon Athena ODBC driver to version 2.1.0.0 to remediate this vulnerability. No other mitigation or temporary fix is indicated. Patch status is confirmed by the vendor advisory. Users should verify they are running version 2.1.0.0 or later to ensure protection against this issue.
Description
Improper certificate validation in the identity provider connection components in Amazon Athena ODBC driver before 2.1.0.0 might allow a man-in-the-middle threat actor to intercept authentication credentials due to insufficient default transport security when connecting to identity providers. This only applies to connections with external identity providers and does not apply to connections with Athena. To remediate this issue, users should upgrade to version 2.1.0.0.
References
- downloads.athena.us-east-1.amazonaws.com/drivers/ODBC/v2.1.0.0/Windows/AmazonAthenaODBC-2.1.0.0.msi (opens in a new tab)
- downloads.athena.us-east-1.amazonaws.com/drivers/ODBC/v2.1.0.0/Linux/AmazonAthenaODBC-2.1.0.0.rpm (opens in a new tab)
- downloads.athena.us-east-1.amazonaws.com/drivers/ODBC/v2.1.0.0/Mac/arm/AmazonAthenaODBC-2.1.0.0_arm.pkg (opens in a new tab)
- downloads.athena.us-east-1.amazonaws.com/drivers/ODBC/v2.1.0.0/Mac/Intel/AmazonAthenaODBC-2.1.0.0_x86.pkg (opens in a new tab)
- aws.amazon.com/security/security-bulletins/2026-013-aws/ (opens in a new tab)
- docs.aws.amazon.com/athena/latest/ug/odbc-v2-driver-release-notes.html (opens in a new tab)