CVE-2026-35570: Gitlawb openclaude · Path Traversal
Affects Gitlawb openclaudeSource CVE Database V5
Not known to be exploited · CVSS 8.4 High : upgrade to 0.5.1 soon.
Data as of 29 Oct 2026, 19:04 UTC
- EPSS
- 0.2% chance of exploitation in 30 days – higher than 14% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 0.5.1
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:NExploitation evidence
Disclosed: evidence found.
CVE published 20 Apr 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: evidence found.
Public exploit code: GitHub proofs of concept
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), GitHub proofs of concept, the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade openclaude and gitlawb/openclaude to 0.5.1.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| Gitlawbopenclaude | Affected
| Fixed in
|
GitHubgitlawb/openclaudepkg:github/gitlawb/openclaudeOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade OpenClaude to version 0.5.1 or later, where the vulnerability is patched. No other official remediation or temporary fixes are documented. Patch status is not explicitly stated but the vendor has released version 0.5.1 containing the fix, so updating to this version is the recommended action.
Description
OpenClaude versions prior to 0.5.1 contain a path traversal vulnerability in the bashToolHasPermission() function. When the sandbox auto-allow feature is enabled without explicit deny rules, path constraints are bypassed, allowing unauthorized access to restricted directories via crafted path traversal sequences. This vulnerability is patched in version 0.5.1.