Skip to main content
VulnerabilityPublished Updated

CVE-2026-36214: osTicket · Cross-site Scripting

Affects osTicketSource CVE Database V5

0

Not known to be exploited · CVSS 5.4 Medium : upgrade to 1.18.4 or 1.17.8 when convenient.

Data as of 26 Oct 2026, 17:16 UTC

CVSS 3.1 base score
5.4Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.3% chance of exploitation in 30 days – higher than 31% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 1.18.4, 1.17.8
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 14 Jul 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade osTicket and osticket/osTicket to 1.18.4 or 1.17.8.

Affected software

ProductAffectedFixed in
osTicketosTicketAffected
  • >=1.18.0 <1.18.4
Fixed in
  • 1.18.4
osTicketosTicketAffected
  • >=1.10.0 <1.17.8
Fixed in
  • 1.17.8
GitHubosticket/osTicketpkg:github/osticket/osTicketOther threatsAffected
  • >=1.10 <1.17.8
  • >=1.18.0 <1.18.4
Fixed in
  • 1.17.8
  • 1.18.4

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

If you cannot patch yet, users should consider restricting access to Agent and Admin interfaces and apply any available workarounds or input sanitization controls.

Description

osTicket versions from 1.10 up to 1.17.7 and from 1.18.0 up to 1.18.3 are vulnerable to a stored XSS due to a vulnerable Bootstrap Tooltip component and insufficient HTML sanitization, allowing remote attackers to execute arbitrary JavaScript in Agent or Admin sessions.

References

Community reviews

Loading reviews…