Skip to main content
VulnerabilityPublished

CVE-2026-3622: TP-Link Systems TL-WR841N v14 · Out-of-bounds Read

Affects TP-Link Systems TL-WR841N v14Source CVE Database V5

0
Compare

Not known to be exploited · CVSS 7.1 High : upgrade to 0.9.1 4.19 soon.

Data as of 30 Oct 2026, 06:59 UTC

CVSS 4.0 base score
7.1High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.3% chance of exploitation in 30 days – higher than 31% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 0.9.1 4.19
CVSS:4.0/AV:A/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 26 Mar 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade TP-Link Systems TL-WR841N v14 to 0.9.1 4.19.

Affected software

ProductAffectedFixed in
TP-Link Systems Inc.TL-WR841N v14Affected
  • =0
Fixed in
  • 0.9.1 4.19

AI-suggested

If you cannot patch yet, consider disabling UPnP on affected devices if feasible to mitigate the risk of service disruption.

Description

CVE-2026-3622 is a high-severity vulnerability in the UPnP component of TP-Link TL-WR841N v14 routers. It arises from improper input validation that causes an out-of-bounds read, potentially crashing the UPnP service. Exploitation leads to a denial-of-service condition by disrupting the UPnP functionality. This affects versions prior to EN_0.9.1 4.19 Build 260303 Rel.42399n and US_0.9.1.

References

Community reviews

Loading reviews…