Skip to main content
VulnerabilityPublished Updated

CVE-2026-36908: Bento4 · Stack-based Buffer Overflow

Affects Bento4Source CVE Database V5

0

Not known to be exploited · CVSS 5.5 Medium : upgrade to 1.8.9 when convenient.

Data as of 26 Oct 2026, 12:55 UTC

CVSS 3.1 base score
5.5Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.1% chance of exploitation in 30 days – higher than 7% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 1.8.9
CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 26 Jun 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade axiomatic-systems/Bento4 to 1.8.9.

Affected software

ProductAffectedFixed in
GitHubaxiomatic-systems/Bento4pkg:github/axiomatic-systems/Bento4Other threatsAffected
  • <1.8.9
Fixed in
  • 1.8.9

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

If you cannot patch yet, avoid processing untrusted MP4 files with affected versions of Bento4.

Description

A stack overflow in the AP4_Array<AP4_TrunAtom::Entry>::EnsureCapacity component of axiomatic-systems Bento4 before v1.8.9allows attackers to cause a Denial of Service (DoS) via a crafted MP4 file.

References

Community reviews

Loading reviews…