CVE-2026-39332: ChurchCRM CRM · Cross-site Scripting
Affects ChurchCRM CRMSource CVE Database V5
Not known to be exploited · CVSS 8.7 High : upgrade to 7.1.0 soon.
Data as of 30 Oct 2026, 11:52 UTC
- EPSS
- 0.2% chance of exploitation in 30 days – higher than 10% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 7.1.0
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:H/A:NExploitation evidence
Disclosed: evidence found.
CVE published 7 Apr 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Upgrade CRM and churchcrm/CRM to 7.1.0.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| ChurchCRMCRM | Affected
| Fixed in
|
GitHubchurchcrm/CRMpkg:github/churchcrm/CRMOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade ChurchCRM to version 7.1.0 or later, where this vulnerability is fixed. No other official remediation or temporary fixes are documented. Until upgrading, restrict authenticated user privileges to minimize risk.
Description
ChurchCRM versions prior to 7.1.0 contain a reflected Cross-Site Scripting (XSS) vulnerability in the GeoPage.php component. This flaw allows any authenticated user to inject arbitrary JavaScript that executes automatically in the browser of another authenticated user without requiring interaction. Exploitation can lead to session cookie theft and full account takeover, including administrator accounts. The vulnerability is fixed in version 7.1.0.