CVE-2026-39336: ChurchCRM CRM · Cross-site Scripting
Affects ChurchCRM CRMSource CVE Database V5
Not known to be exploited · CVSS 6.1 Medium : upgrade to 7.1.0 when convenient.
Data as of 30 Oct 2026, 11:52 UTC
- EPSS
- 0.2% chance of exploitation in 30 days – higher than 10% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 7.1.0
CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:U/C:H/I:H/A:NExploitation evidence
Disclosed: evidence found.
CVE published 7 Apr 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Upgrade CRM and churchcrm/CRM to 7.1.0.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| ChurchCRMCRM | Affected
| Fixed in
|
GitHubchurchcrm/CRMpkg:github/churchcrm/CRMOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade ChurchCRM to version 7.1.0 or later, where this stored XSS vulnerability is fixed. Since this is not a cloud service, remediation depends on applying this official fix. Patch status is confirmed by the vendor's versioning information. No additional mitigations are specified or required beyond applying the update.
Description
ChurchCRM is an open-source church management system. Prior to 7.1.0, a stored cross-site scripting issue affects the Directory Reports form fields set from config, Person editor defaults rendered into address fields, and external self-registration form defaults. This is primarily an admin-to-admin stored XSS path where writable configuration fields are abused. This vulnerability is fixed in 7.1.0.