Skip to main content
VulnerabilityPublished

CVE-2026-39356: drizzle-orm · SQL Injection

Affects drizzle-ormSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 7.5 High : upgrade to 1.0.0-beta.20 or 0.45.2 soon.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 3.1 base score
7.5High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.3% chance of exploitation in 30 days – higher than 33% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 1.0.0-beta.20, 0.45.2
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 7 Apr 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade drizzle-orm to 1.0.0-beta.20 or 0.45.2; drizzle-orm to 0.45.2.

Affected software

ProductAffectedFixed in
drizzle-teamdrizzle-ormAffected
  • >=1.0.0-beta.2 <1.0.0-beta.20
Fixed in
  • 1.0.0-beta.20
drizzle-teamdrizzle-ormAffected
  • <0.45.2
Fixed in
  • 0.45.2
npmdrizzle-ormpkg:npm/drizzle-ormOther threatsAffected
  • <0.45.2
Fixed in
  • 0.45.2

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

This vulnerability is fixed in drizzle-orm versions 0.45.2 and 1.0.0-beta.20. Users should upgrade to at least these versions to remediate the issue. Patch status is not explicitly stated in the vendor advisory, but the fix is included in these versions. Until upgraded, avoid passing untrusted input to APIs that construct SQL identifiers or aliases such as sql.identifier() and .as().

Description

CVE-2026-39356 is a high-severity SQL injection vulnerability in the drizzle-orm TypeScript ORM. Versions prior to 0.45.2 and before 1.0.0-beta.20 improperly escape quoted SQL identifiers, allowing attacker-controlled input to break out of quoted identifiers and inject SQL commands. This occurs in APIs that construct SQL identifiers or aliases, such as sql.identifier() and . as().

References

Community reviews

Loading reviews…