CVE-2026-39376: kagisearch fastfeedparser · Uncontrolled Recursion
Affects kagisearch fastfeedparserSource CVE Database V5
Not known to be exploited · CVSS 7.5 High : upgrade to 0.5.10 soon.
Data as of 30 Oct 2026, 06:59 UTC
- EPSS
- 0.3% chance of exploitation in 30 days – higher than 25% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 0.5.10
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:HExploitation evidence
Disclosed: evidence found.
CVE published 7 Apr 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: evidence found.
Public exploit code: GitHub proofs of concept
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), GitHub proofs of concept, the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade kagisearch fastfeedparser to 0.5.10.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| kagisearchfastfeedparser | Affected
| Fixed in
|
PyPIfastfeedparserpkg:pypi/fastfeedparserOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade fastfeedparser to version 0.5.10 or later, where this uncontrolled recursion issue is fixed. Patch status is confirmed by the vendor stating the fix is included in version 0.5.10. No additional mitigation is indicated.
Description
CVE-2026-39376 is a high-severity vulnerability in the fastfeedparser component of kagisearch versions prior to 0.5.10. The parser recursively follows HTML meta-refresh redirects without any limit on recursion depth, visited URL deduplication, or redirect count cap. This can lead to unbounded recursion, exhausting the Python call stack and causing the process to crash. The vulnerability can be combined with a server-side request forgery (SSRF) issue to target internal networks. The issue is fixed in version 0.5.10.