Skip to main content
CVE-2026-39390VulnerabilityPublished

CVE-2026-39390: ci4-cms-erp ci4ms · Cross-site Scripting

Affects ci4-cms-erp ci4msSource CVE Database V5

0

Not known to be exploited · CVSS 5.5 Medium : upgrade to 0.31.4.0 when convenient.

Data as of 26 Oct 2026, 06:26 UTC

CVSS 3.1 base score
5.5Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 14% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 0.31.4.0
CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:L/I:L/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 8 Apr 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-26.

What to do

Upgrade ci4ms and ci4-cms-erp/ci4ms to 0.31.4.0.

Affected software

ProductAffectedFixed in
ci4-cms-erpci4msAffected
  • <0.31.4.0
Fixed in
  • 0.31.4.0
GitHubci4-cms-erp/ci4mspkg:github/ci4-cms-erp/ci4msOther threatsAffected
  • <0.31.4.0
Fixed in
  • 0.31.4.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

This vulnerability is fixed in ci4ms version 0.31.4.0. Users should upgrade to version 0.31.4.0 or later to remediate this issue. No other official remediation or temporary fixes are documented. Since this is not a cloud service, patching the affected software version is required to mitigate the risk.

Description

CI4MS is a CodeIgniter 4-based CMS skeleton that delivers a production-ready, modular architecture with RBAC authorization and theme support. Prior to 0.31.4.0, the Google Maps iframe setting (cMap field) in compInfosPost() sanitizes input using strip_tags() with an <iframe> allowlist and regex-based removal of on\w+ event handlers. However, the srcdoc attribute is not an event handler and passes all filters. An attacker with admin settings access can inject an <iframe srcdoc="..."> payload with HTML-entity-encoded JavaScript that executes in the context of the parent page when rendered to unauthenticated frontend visitors. This vulnerability is fixed in 0.31.4.0.

References

Community reviews

Loading reviews…