Skip to main content
VulnerabilityPublished

CVE-2026-39397: delmaredigital payload-puck · Missing Authorization

Affects delmaredigital payload-puckSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 9.4 Critical : upgrade to 0.6.23 as a priority.

Data as of 29 Oct 2026, 19:04 UTC

CVSS 3.1 base score
9.4Critical
How severe the flaw is on the 0–10 CVSS scale.

Contested

Critical score, yet low EPSS after six months
EPSS
0.3% chance of exploitation in 30 days – higher than 31% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 0.6.23
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:L

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 7 Apr 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade delmaredigital payload-puck to 0.6.23.

Affected software

ProductAffectedFixed in
delmaredigitalpayload-puckAffected
  • <0.6.23
Fixed in
  • 0.6.23

AI-suggested

Upgrade the payload-puck plugin to version 0.6.23 or later, where this authorization bypass vulnerability is fixed. Since no official vendor advisory or patch link is provided, users should verify the plugin version and apply the update promptly. Until updated, restrict access to the affected API endpoints if possible to reduce exposure.

Description

@delmaredigital/payload-puck is a PayloadCMS plugin for integrating Puck visual page builder. Prior to 0.6.23, all /api/puck/* CRUD endpoint handlers registered by createPuckPlugin() called Payload's local API with the default overrideAccess: true, bypassing all collection-level access control. The access option passed to createPuckPlugin() and any access rules defined on Puck-registered collections were silently ignored on these endpoints. This vulnerability is fixed in 0.6.23.

References

Community reviews

Loading reviews…