Skip to main content
VulnerabilityPublished Updated

CVE-2026-39400: jhuckaby Cronicle · Cross-site Scripting

Affects jhuckaby CronicleSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 5.3 Medium : upgrade to 0.9.111 when convenient.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 4.0 base score
5.3Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.1% chance of exploitation in 30 days – higher than 6% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 0.9.111
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 7 Apr 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade Cronicle and jhuckaby/Cronicle to 0.9.111.

Affected software

ProductAffectedFixed in
jhuckabyCronicleAffected
  • <0.9.111
Fixed in
  • 0.9.111
GitHubjhuckaby/Croniclepkg:github/jhuckaby/CronicleOther threatsAffected
  • <0.9.111
Fixed in
  • 0.9.111

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade Cronicle to version 0.9.111 or later, where this vulnerability is fixed. Since the vulnerability is resolved in this version, applying this update is the recommended remediation. No additional vendor advisory or patch links are provided, but the version upgrade is the definitive fix.

Description

Cronicle is a multi-server task scheduler and runner, with a web based front-end UI. Prior to 0.9.111, a non-admin user with create_events and run_events privileges can inject arbitrary JavaScript through job output fields (html.content, html.title, table.header, table.rows, table.caption). The server stores this data without sanitization, and the client renders it via innerHTML on the Job Details page. This vulnerability is fixed in 0.9.111.

References

Community reviews

Loading reviews…