Skip to main content
VulnerabilityPublished

CVE-2026-39406: honojs node-server · Path Traversal

Affects honojs node-serverSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 5.3 Medium : upgrade to 1.19.13 when convenient.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 3.1 base score
5.3Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.3% chance of exploitation in 30 days – higher than 31% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 1.19.13
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 8 Apr 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade node-server and honojs/node-server to 1.19.13.

Affected software

ProductAffectedFixed in
honojsnode-serverAffected
  • <1.19.13
Fixed in
  • 1.19.13
npmhonojs/node-serverpkg:npm/honojs/node-serverOther threatsAffected
  • <1.19.13
Fixed in
  • 1.19.13

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade honojs node-server to version 1.19.13 or later, where this path traversal vulnerability is fixed. Until upgraded, avoid relying solely on route-based middleware for authorization of static files or implement additional path normalization checks.

Description

CVE-2026-39406 is a path traversal vulnerability in honojs node-server versions prior to 1.19.13. The issue arises from inconsistent path handling in the serveStatic function, which normalizes repeated slashes in request paths. When route-based middleware is used for authorization, paths containing repeated slashes may bypass middleware checks, allowing unauthorized access to protected static files. This vulnerability has a CVSS score of 5.3 (medium severity) and does not affect availability or integrity, only confidentiality to a limited extent. The vulnerability is fixed in version 1.19.13.

References

Community reviews

Loading reviews…