CVE-2026-39425: 1Panel-dev MaxKB · Basic XSS
Affects 1Panel-dev MaxKBSource CVE Database V5
Not known to be exploited · CVSS 5.1 Medium : upgrade to 2.8.0 when convenient.
Data as of 30 Oct 2026, 11:52 UTC
- EPSS
- 0.1% chance of exploitation in 30 days – higher than 7% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 2.8.0
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:P/VC:L/VI:L/VA:N/SC:L/SI:L/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 14 Apr 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Upgrade MaxKB and 1panel-dev/MaxKB to 2.8.0.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| 1Panel-devMaxKB | Affected
| Fixed in
|
GitHub1panel-dev/MaxKBpkg:github/1panel-dev/MaxKBOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade MaxKB to version 2.8.0 or later, where this vulnerability has been fixed. Since the vendor advisory confirms the fix in 2.8.0, applying this official update fully mitigates the issue.
Description
MaxKB versions 2.7.1 and below contain a stored cross-site scripting (XSS) vulnerability in the Application prologue field. Authenticated users can inject arbitrary HTML and JavaScript by using <html_rander> tags, which the backend does not sanitize before storing. The frontend renders this content unsafely, enabling persistent XSS that affects any visitor opening the chatbot interface. Exploitation may lead to session hijacking, unauthorized actions, and data exposure. This vulnerability is fixed in version 2.8.0.