Skip to main content
VulnerabilityPublished

CVE-2026-39459: F5 BIG-IP · Least Privilege Violation

Affects F5 BIG-IPSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 7.2 High · fixed in 21.0.0.2 : patch F5 BIG-IP soon.

Data as of 29 Oct 2026, 19:04 UTC

CVSS 3.1 base score
7.2High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 17% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 21.0.0.2, 17.5.1.6, 17.1.3.2
CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 13 May 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade F5 BIG-IP to 21.0.0.2, 17.5.1.6 or 17.1.3.2.

Affected software

ProductAffectedFixed in
F5BIG-IPAffected
  • >=21.0.0 <21.0.0.2
  • >=17.5.0 <17.5.1.6
  • >=17.1.0 <17.1.3.2
  • >=16.1.0
Fixed in
  • 21.0.0.2
  • 17.5.1.6
  • 17.1.3.2

AI-suggested

If you cannot patch yet, restrict Manager role assignments to trusted personnel only and monitor for unusual configuration changes. Avoid using versions listed as affected if possible, or consider upgrading to versions not listed once vendor guidance is available.

Description

CVE-2026-39459 is a high-severity vulnerability in F5 BIG-IP affecting iControl REST and TMOS Shell (tmsh). It allows a highly privileged, authenticated attacker with at least the Manager role to create configuration objects that enable running arbitrary commands. This violates the principle of least privilege and could lead to full system compromise. The affected versions include 16.1.0, 17.1.0, 17.5.0, and 21.

References

Community reviews

Loading reviews…