CVE-2026-39472: WooCommerce PDF Invoices & Packing Slips (WordPress plugin) · Deserialization of Untrusted Data
Affects WooCommerce PDF Invoices & Packing Slips (WordPress plugin)Source CVE Database V5
Not known to be exploited · CVSS 7.2 High : upgrade to 5.9.0 soon.
Data as of 30 Oct 2026, 11:52 UTC
- EPSS
- 0.4% chance of exploitation in 30 days – higher than 38% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 5.9.0
CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 15 Jun 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Upgrade WooCommerce PDF Invoices & Packing Slips (WordPress plugin) to 5.9.0.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| WP OvernightWooCommerce PDF Invoices & Packing Slips | Affected
| Fixed in
|
AI-suggested
If you cannot patch yet, restrict shop manager privileges to trusted users only and monitor for suspicious activity related to the plugin. Avoid importing or processing untrusted serialized data within the plugin's context.
Description
A high-severity vulnerability (CVE-2026-39472) exists in WP Overnight's WooCommerce PDF Invoices & Packing Slips plugin before version 5.9.0. It involves PHP Object Injection due to deserialization of untrusted data by users with shop manager privileges. This can lead to complete compromise of confidentiality, integrity, and availability of the affected system.