Skip to main content
VulnerabilityPublished

CVE-2026-39596: Blocksy Companion Pro (WordPress plugin) · SQL Injection

Affects Blocksy Companion Pro (WordPress plugin)Source CVE Database V5

0
Compare

Not known to be exploited · CVSS 9.3 Critical : upgrade to 2.1.29 as a priority.

Data as of 31 Oct 2026, 08:20 UTC

CVSS 3.1 base score
9.3Critical
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.3% chance of exploitation in 30 days – higher than 31% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 2.1.29
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:N/A:L

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 17 Jun 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade Blocksy Companion Pro (WordPress plugin) to 2.1.29.

Affected software

ProductAffectedFixed in
Creative ThemesBlocksy Companion ProAffected
  • ≥ n/a, < 2.1.29
Fixed in
  • 2.1.29

AI-suggested

No vendor advisory or official patch is currently available.

Description

Unauthenticated SQL Injection in Blocksy Companion Pro < 2.1.29 versions.

References

Community reviews

Loading reviews…