CVE-2026-39816: Apache NiFi · Missing Authorization
Affects Apache NiFiSource CVE Database V5
Not known to be exploited · CVSS 7.5 High · fixed in 2.9.0 : patch Apache NiFi soon.
Data as of 29 Oct 2026, 19:04 UTC
- EPSS
- 0.7% chance of exploitation in 30 days – higher than 55% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 2.9.0
CVSS:4.0/AV:N/AC:L/AT:P/PR:H/UI:N/VC:H/VI:H/VA:H/SC:L/SI:L/SA:L/AU:Y/R:I/V:C/RE:L/U:GreenExploitation evidence
Disclosed: evidence found.
CVE published 8 May 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: evidence found.
Public exploit code: GitHub proofs of concept
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), GitHub proofs of concept, the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| Apache Software FoundationApache NiFi | Affected
| Fixed in– |
Mavenorg.apache.nifi/nifipkg:maven/org.apache.nifi/nifiOther threats | Affected
| Fixed in– |
MavenApache Software Foundation/org.apache.nifi:nifi-other-graph-services-narpkg:maven/Apache Software Foundation/org.apache.nifi:nifi-other-graph-services-narOther threats | Affected
| Fixed in– |
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrading to Apache NiFi version 2.9.0 or later is the recommended mitigation to address this vulnerability. Patch status is not explicitly confirmed in the advisory, but the upgrade recommendation indicates an official fix is available in 2.9.0. Installations not using the nifi-other-graph-services-nar component are not affected and require no action related to this vulnerability.
Description
The optional extension component TinkerpopClientService is missing the Restricted annotation with the Execute Code Required Permission in Apache NiFi 2.0.0-M1 through 2.8.0. The TinkerpopClientService supports configuration of ByteCode Submission for the Script Submission Type, enabling Groovy Script execution in the service prior to submitting the query. The missing Restricted annotation allows users without the Execute Code Permission to configure the Service in installations that use fine-grained authorization and have the optional TinkerpopClientService installed. Apache NiFi installations that do not have the nifi-other-graph-services-nar installed are not subject to this vulnerability. Upgrading to Apache NiFi 2.9.0 is the recommended mitigation.