CVE-2026-39857: apostrophecms apostrophe · Information Exposure
Affects apostrophecms apostropheSource CVE Database V5
Not known to be exploited · CVSS 5.3 Medium : upgrade to 4.29.0 when convenient.
Data as of 30 Oct 2026, 06:59 UTC
- EPSS
- 0.4% chance of exploitation in 30 days – higher than 37% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 4.29.0
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:NExploitation evidence
Disclosed: evidence found.
CVE published 15 Apr 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade apostrophe and apostrophecms/apostrophe to 4.29.0.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| apostrophecmsapostrophe | Affected
| Fixed in
|
GitHubapostrophecms/apostrophepkg:github/apostrophecms/apostropheOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
This vulnerability has been fixed in ApostropheCMS version 4.29.0. Users should upgrade to version 4.29.0 or later to remediate this issue. Since this is not a cloud service, remediation depends on applying the vendor's fixed version.
Description
ApostropheCMS versions 4.28.0 and earlier have an authorization bypass vulnerability in the REST API's choices and counts query parameters. This flaw allows unauthenticated attackers to retrieve distinct values of any schema field, including those protected by view permissions, bypassing intended field exposure restrictions. The vulnerability arises because MongoDB's distinct() operation does not respect the publicApiProjection filtering, resulting in sensitive data exposure. The issue affects both piece-type and page REST APIs and has been fixed in version 4.29.0.