CVE-2026-39861: anthropics claude-code · Path Traversal
Affects anthropics claude-codeSource CVE Database V5
Not known to be exploited · CVSS 7.7 High : upgrade to 2.1.64 soon.
Data as of 29 Oct 2026, 19:04 UTC
- EPSS
- 0.7% chance of exploitation in 30 days – higher than 53% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 2.1.64
CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:P/VC:H/VI:H/VA:H/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 21 Apr 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade claude-code and anthropics/claude-code to 2.1.64.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| anthropicsclaude-code | Affected
| Fixed in
|
GitHubanthropics/claude-codepkg:github/anthropics/claude-codeOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Users who rely on standard Claude Code auto-update mechanisms have already received the fix. Those performing manual updates should upgrade to version 2.1.64 or later to remediate this vulnerability. No additional mitigation steps are indicated by the vendor advisory.
Description
Claude Code versions prior to 2.1.64 contain a path traversal vulnerability in their sandbox implementation. The sandbox did not prevent sandboxed processes from creating symbolic links pointing outside the workspace. When the unsandboxed process wrote to a path through such a symlink, it could write outside the intended sandbox without user confirmation. This combination allows sandbox escape and potential code execution outside the sandbox. Exploitation requires injecting untrusted content to trigger sandboxed code execution. Users with standard auto-updates have received the fix; manual update to version 2.1.64 or later is advised.