Skip to main content
VulnerabilityPublished

CVE-2026-39886: AcademySoftwareFoundation openexr · Integer Overflow or Wraparound

Affects AcademySoftwareFoundation openexrSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 5.3 Medium : upgrade to 3.4.10 when convenient.

Data as of 30 Oct 2026, 06:59 UTC

CVSS 3.1 base score
5.3Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.3% chance of exploitation in 30 days – higher than 22% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 3.4.10
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 21 Apr 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade AcademySoftwareFoundation openexr to 3.4.10.

Affected software

ProductAffectedFixed in
AcademySoftwareFoundationopenexrAffected
  • >=3.4.0 <3.4.10
Fixed in
  • 3.4.10
GitHubacademysoftwarefoundation/openexrpkg:github/academysoftwarefoundation/openexrOther threatsAffected
  • 3.4.0 – 3.4.9
10 affected builds
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fix for this vulnerability is available in OpenEXR version 3.4.10. Users should upgrade to version 3.4.10 or later to remediate this issue. Patch status is not explicitly stated beyond the version containing the fix; therefore, verify with the vendor advisory for the latest remediation guidance.

Description

OpenEXR versions 3.4.0 through 3.4.9 contain a signed integer overflow vulnerability in the HTJ2K decompression path. The vulnerability occurs in the ht_undo_impl() function where a 32-bit signed integer accumulator for bytes-per-line (bpl) can overflow when processing a specially crafted EXR file with a large number of FLOAT channels and maximum width. This overflow can lead to undefined behavior and potentially a heap out-of-bounds write on hosts that allow large memory allocations. Version 3.4.10 includes a fix for this issue.

References

Community reviews

Loading reviews…