Skip to main content
VulnerabilityPublished Updated

CVE-2026-39918: givanz Vvveb · Code Injection

Affects givanz VvvebSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 9.2 Critical : upgrade to 1.0.8.1 as a priority.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 4.0 base score
9.2Critical
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.6% chance of exploitation in 30 days – higher than 51% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 1.0.8.1
CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 20 Apr 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade Vvveb and givanz/Vvveb to 1.0.8.1.

Affected software

ProductAffectedFixed in
givanzVvvebAffected
  • <1.0.8.1
Fixed in
  • 1.0.8.1
GitHubgivanz/Vvvebpkg:github/givanz/VvvebOther threatsAffected
  • <1.0.8.1
Fixed in
  • 1.0.8.1
GitHubVvvebpkg:github/VvvebOther threatsAffected
  • <1.0.8.1
Fixed in
  • 1.0.8.1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

If you cannot patch yet, restrict access to the installation endpoint and avoid exposing it to untrusted networks. Monitor for vendor updates regarding a security patch.

Description

Vvveb prior to 1.0.8.1 contains a code injection vulnerability in the installation endpoint where the subdir POST parameter is written unsanitized into the env.php configuration file without escaping or validation. Attackers can inject arbitrary PHP code by breaking out of the string context in the define statement to achieve unauthenticated remote code execution as the web server user.

References

Community reviews

Loading reviews…