Skip to main content
VulnerabilityPublished

CVE-2026-39941: ChurchCRM CRM · Cross-site Scripting

Affects ChurchCRM CRMSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 5.3 Medium : upgrade to 7.1.0 when convenient.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 4.0 base score
5.3Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 18% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 7.1.0
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 9 Apr 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 24 Oct 2026.

What to do

Upgrade CRM and churchcrm/CRM to 7.1.0.

Affected software

ProductAffectedFixed in
ChurchCRMCRMAffected
  • <7.1.0
Fixed in
  • 7.1.0
GitHubchurchcrm/CRMpkg:github/churchcrm/CRMOther threatsAffected
  • <7.1.0
Fixed in
  • 7.1.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade ChurchCRM to version 7.1.0 or later, where this XSS vulnerability has been fixed. Since this is a self-hosted application, administrators must apply the update manually. Patch status is confirmed by the vendor's versioning information. No additional mitigations are specifically indicated.

Description

ChurchCRM is an open-source church management system. Prior to 7.1.0, an XSS vulnerability allows attacker-supplied input sent via a the EName and EDesc parameters in EditEventAttendees.php to be rendered in a page without proper output encoding, enabling arbitrary JavaScript execution in victims' browsers. This vulnerability is fixed in 7.1.0.

References

Community reviews

Loading reviews…