CVE-2026-39970: baptisteArno typebot.io · Cross-site Scripting
Affects baptisteArno typebot.ioSource CVE Database V5
Not known to be exploited · CVSS 8.5 High : upgrade to 3.16.0 soon.
Data as of 30 Oct 2026, 11:52 UTC
- EPSS
- 0.2% chance of exploitation in 30 days – higher than 20% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 3.16.0
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:P/VC:H/VI:H/VA:N/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 22 May 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Upgrade typebot.io and baptistearno/typebot.io to 3.16.0.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| baptisteArnotypebot.io | Affected
| Fixed in
|
GitHubbaptistearno/typebot.iopkg:github/baptistearno/typebot.ioOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade TypeBot to version 3.16.0 or later, where this vulnerability has been fixed. Versions prior to 3.16.0 are vulnerable due to lack of proper SVG/XML sanitization in the profile picture upload form. No other mitigation is indicated by the vendor advisory.
Description
TypeBot versions 3.15.2 and earlier contain a critical stored cross-site scripting (XSS) vulnerability in the profile picture upload form. The application does not properly sanitize SVG/XML uploads, allowing attackers to upload malicious SVG files with embedded JavaScript. This payload is persistently stored and publicly accessible, enabling execution of arbitrary JavaScript in users' browsers. Exploitation can lead to session theft, account takeover, and data exfiltration. The vulnerability is fixed in version 3.16.0.